Just a quick announcement…Toggl is compatible with Firefox 2. So you should be just fine with using the latest in browser technologies.

Cheers,

Alari